WebApp v1.5.1 scheduled to be released
Resolved
May 26, 2026 at 2:00pm UTC
Maintenance ended
Affected services
Created
May 26, 2026 at 12:00pm UTC
New Features & Improvements
Reworked Navigation Experience
We’ve redesigned parts of the navigation structure to make it easier to move through your projects and experiments. The updated layout improves clarity and helps you find the right information and actions more quickly, especially when working across multiple workflows and datasets.
Analysis and Library Sections are Now Separated
The platform navigation has now been split into two distinct areas: Analysis and Library.
The Analysis section is now focused purely on the work you actively perform in DECTRIS CLOUD, including:
Sessions
Jobs
The new Library section is dedicated to reusable resources, including:
Private and public environments
Private and public job templates
This separation creates a clearer distinction between doing analysis and managing reusable tooling, resulting in a more intuitive and organized experience across the platform.
Affected services